解决Lombok失效问题, IDEA 2020.3 默认集成 Lombok

Stardust 2020年12月16日 71次浏览

Lombok是IDEA的必备插件之一,甚至不少人要求将Lombok集成到IDEA

现在,IDEA 2020.3正式版已经这样做了,经过测试 IDEA 2020.3 不需要安装Lombok插件即可实现同样的功能。

如果你也注意到了IDEA 的升级界面显示2020.3与Lombok不兼容的警告,你不必等待Lombok的更新,请直接卸载Lombok插件,然后升级到2020.3即可。在我的项目中,完全不需要再安装Lombok插件,也不需要额外的设置。

需要注意的是只有旗舰版在安装时集成了Lombok,社区版没有集成Lombok,但是可以从插件市场安装相同的版本。

在升级之前一定记得卸载Lombok,不然可能发生意想不到的错误

image.png