上一篇 下一篇 回到顶部 目录 分享文章 返回首页
目录

Halo迁移

918
  1. 备份 ~/.halo 和 /etc/caddy/conf.d/Caddyfile.conf 。
  2. 将 ~/.halo 复制到新机器的 ~/.halo目录下 。
  3. 下载最新的halo-latest.jar,并启动:java -jar halo-latest.jar。
  4. 测试IP:8090和IP:8090/admin,确认服务正常。
  5. 配置Halo自启:官网教程。
  6. 安装Caddy:yum install caddy -y。
  7. 将 Caddyfile.conf 复制到新机器的 /etc/caddy/conf.d/。
  8. 打开防火墙的端口,服务器的防火墙和云服务商的安全组都要打开,TCP和UDP都要打开:80、443。
  9. 将域名解析到新的服务器。
  10. 配置Caddy自启:systemctl enable caddy。
  11. 启动Caddy:service caddy start,DNS延迟可能会导致启动失败,等待10~20分钟;Caddyfile.conf的权限可能会导致启动失败,设置为755。
  12. 访问域名即可。